Restore Fuel L1 firmware after broken update

From Nekochan
Revision as of 02:06, 11 May 2012 by Regan russell (Talk | contribs) (Created page with " It turns out that this combination of -003 motherboard and 1.44.0 L1 firmware renders the system unbootable. Won't respond to power button, verbal abuse, nothing. Remove t...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


It turns out that this combination of -003 motherboard and 1.44.0 L1 firmware renders the system unbootable. Won't respond to power button, verbal abuse, nothing.


Remove the machine's side panel. Somewhere near the SCSI connector on the motherboard you will find an RS232 port, attach a null-modem cable to it. On the other machine, start a terminal emulator ('cu' works well), set it to 38400 8N1 (e.g. 'cu -l /dev/your_serial_port -s 38400'). As soon as you plug in the power cable on the Fuel, you should be greeted by a prompt:

ALERT: Error reading the display I/O expander, no acknowledge


SGI SN1 L1 Controller
Firmware Image A: Rev. 1.44.0, Built 07/17/2006 18:19:54


001?01-L1>

The following entries in the log appeared at the time of the update:

09/29/09 21:21:28 L1 booting 1.44.0
09/29/09 21:21:28 vram checksum error - initializing core data.
09/29/09 21:21:28 ALERT: Error reading the display I/O expander, no acknowledge
09/29/09 21:21:28 ** fixing invalid SSN value

If you try to issue a power up command, you will receive this lovely message: Code:

001?01-L1>pwr up
ERROR: no power supplies available.

Resetting the NVRAM didn't help, so I decided to boot the other L1 image.

001?01-L1>flash status
Flash image A currently booted

Image      Status        Revision    Built
-----   -------------   ----------   -----
  A     default         1.44.0       07/17/2006 18:19:54
  B     valid           1.10.12      02/01/2002 14:40:22
001?01-L1>flash default b

(if your L1 booted from image B, enter "flash default a" instead)

001?01-L1>reboot_l1


After this, everything works normally:

SGI SN1 L1 Controller
Firmware Image B: Rev. 1.10.12, Built 02/01/2002 14:40:22


001a01-L1>flash status
Flash image B currently booted

Image      Status        Revision    Built
-----   -------------   ----------   -----
  A     valid           1.44.0       07/17/2006 18:19:54
  B     user default    1.10.12      02/01/2002 14:40:22